Results 1 to 6 of 6

Thread: Bot ain't responding on reach depot - HELP!

  1. #1
    Normal User
    Join Date
    Jun 2012
    Posts
    31
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    10
    Rep Power
    5

    Bot ain't responding on reach depot - HELP!

    What's wrong with this? Because the bot are just skipping this action and continues the waypoint....

    reachgrounditem("depot")
    wait(1000, 2000)
    openitem("depot")
    wait(500)
    openitem(3502, "locker")
    wait(500)
    openitem(MainDPBP, 3502)

  2. #2
    Normal User
    Join Date
    Jun 2012
    Posts
    31
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    10
    Rep Power
    5
    Tried to create a script and took some actions from Bofing - hope that's okay with you Bofing, wanted to learn from a pro, heh. Works fine with his items but whenever I change the deposititems the bot ignores the action.

    reachgrounditem("depot")
    wait(1000, 2000)
    openitem(MainBP, "back")
    wait(500)
    openitem("depot")
    wait(1000, 2000)
    openitem(3502, 'locker')
    wait(1000, 2000)
    openitem(MainDPBP, 3502)
    wait(1000, 2000)

    --stack items
    depotdeposit(StackDPBP, "hair of a banshee", "mutated bat ear", "black pearl", "white pearl", "small amethyst", "petrified scream", "bat wing", "spider silk", "hardened bone", "bony tail", "half disgested piece of meat", "piece of scarab shell", "rotten piece of cloth", "pelvis bone", "flask of embalming fluid", "scorpion tail", "pile of grave earth", "cobra tongue")

    --non stack items
    depotdeposit(LootDPBP, "red robe", "blue robe", "batwing hat", "ring of healing", “black shield”, “mercenary sword”, “stone skin amulet”, “knight legs”, “knight armor”, “time ring”, “lightning headband”, “platinum amulet”, “terra mantle”, “castle shield”, “lightning boots”, “maxilla maximus”, “bonebeast trophy”)

    openitem(LootBP, MainBP)
    wait(500,1000)

    --stack items
    depotdeposit(StackDPBP, "hair of a banshee", "mutated bat ear", "black pearl", "white pearl", "small amethyst", "petrified scream", "bat wing", "spider silk", "hardened bone", "bony tail", "half disgested piece of meat", "piece of scarab shell", "rotten piece of cloth", "pelvis bone", "flask of embalming fluid", "scorpion tail", "pile of grave earth", "cobra tongue")

    --non stack items
    depotdeposit(LootDPBP, "red robe", "blue robe", "batwing hat", "ring of healing", “black shield”, “mercenary sword”, “stone skin amulet”, “knight legs”, “knight armor”, “time ring”, “lightning headband”, “platinum amulet”, “terra mantle”, “castle shield”, “lightning boots”, “maxilla maximus”, “bonebeast trophy”)
    That doesn't work. The bot are just ignoring that action as if it never existed. Altough, this action works fine:

    reachgrounditem("depot")
    wait(1000, 2000)
    openitem(MainBP, "back")
    wait(500)
    openitem("depot")
    wait(1000, 2000)
    openitem(3502, 'locker')
    wait(1000, 2000)
    openitem(MainDPBP, 3502)
    wait(1000, 2000)

    --stack items
    depotdeposit(StackDPBP, "mutated flesh", "glob of mercury", "black pearl", "small emerald", "small amethyst", "brown piece of cloth", "scarab coin", "gauze bandage", "miraculum", "ghoul snack", "half disgested piece of meat", "piece of scarab shell", "rotten piece of cloth", "pelvis bone", "flask of embalming fluid", "scorpion tail", "pile of grave earth", "cobra tongue")

    --non stack items
    depotdeposit(LootDPBP, "mini mummy", "black shield", "obsidian lance", "life ring")

    openitem(LootBP, MainBP)
    wait(500,1000)

    --stack items
    depotdeposit(StackDPBP, "mutated flesh", "glob of mercury", "black pearl", "small emerald", "small amethyst", "brown piece of cloth", "scarab coin", "gauze bandage", "miraculum", "ghoul snack", "half disgested piece of meat", "piece of scarab shell", "rotten piece of cloth", "pelvis bone", "flask of embalming fluid", "scorpion tail", "pile of grave earth", "cobra tongue")

    --non stack items
    depotdeposit(LootDPBP, "mini mummy", "black shield", "obsidian lance", "life ring")
    As you can see it's basicually the same action but with different items. Odd, isn't?

  3. #3
    Normal User
    Join Date
    Jun 2012
    Posts
    31
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    10
    Rep Power
    5
    Not sure on how many replies I can create but I realized it's not wrong with the

    reachgrounditem("depot")
    wait(1000, 2000)
    openitem(MainBP, "back")
    wait(500)
    openitem("depot")
    wait(1000, 2000)
    openitem(3502, 'locker')
    wait(1000, 2000)
    openitem(MainDPBP, 3502)
    wait(1000, 2000)
    IBot are ignoring that action which contains:

    --stack items
    depotdeposit(StackDPBP, "mutated flesh", "glob of mercury", "black pearl", "small emerald", "small amethyst", "brown piece of cloth", "scarab coin", "gauze bandage", "miraculum", "ghoul snack", "half disgested piece of meat", "piece of scarab shell", "rotten piece of cloth", "pelvis bone", "flask of embalming fluid", "scorpion tail", "pile of grave earth", "cobra tongue")

    --non stack items
    depotdeposit(LootDPBP, "mini mummy", "black shield", "obsidian lance", "life ring")

    openitem(LootBP, MainBP)
    wait(500,1000)

    --stack items
    depotdeposit(StackDPBP, "mutated flesh", "glob of mercury", "black pearl", "small emerald", "small amethyst", "brown piece of cloth", "scarab coin", "gauze bandage", "miraculum", "ghoul snack", "half disgested piece of meat", "piece of scarab shell", "rotten piece of cloth", "pelvis bone", "flask of embalming fluid", "scorpion tail", "pile of grave earth", "cobra tongue")

    --non stack items
    depotdeposit(LootDPBP, "mini mummy", "black shield", "obsidian lance", "life ring")
    so I tried this with no luck at all:

    depotdeposit('StackDPBP', "hair of a banshee", "mutated bat ear", "black pearl", "white pearl", "small amethyst", "petrified scream", "bat wing", "spider silk", "hardened bone", "bony tail", "half disgested piece of meat", "piece of scarab shell", "rotten piece of cloth", "pelvis bone", "piece of dead brain", "bonelord eye", "pile of grave earth", "cobra tongue")

    depotdeposit('LootDPBP', "red robe", "blue robe", "batwing hat", "ring of healing", “black shield”, “mercenary sword”, “stone skin amulet”, “knight legs”, “knight armor”, “time ring”, “lightning headband”, “platinum amulet”, “terra mantle”, “castle shield”, “lightning boots”, “maxilla maximus”, “bonebeast trophy”, 'haunted blade', "spiked squelcher", "bonelord shield", "bonelord helmet")
    wait(500,1000)
    Still, I can't deposit the items I'd like to deposit.

    Won't post another reply, will edit if I've something else to say!

  4. #4
    Banned
    Join Date
    May 2012
    Location
    Rio de Janero - RJ / Canada
    Posts
    870
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    30
    Rep Power
    0
    check ur debug log

    Help > Debug
    and post here

  5. #5
    Normal User
    Join Date
    Jun 2012
    Posts
    31
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    10
    Rep Power
    5
    Says:
    "LUA:PersistentAction - LuaInterface.LuaScriptException:[string "chunk"]:2:''expected near 'end'

  6. #6
    Normal User
    Join Date
    Jun 2012
    Location
    Sweden
    Posts
    1,671
    Mentioned
    18 Post(s)
    Tagged
    1 Thread(s)
    Quoted
    8 Post(s)
    Reputation
    132
    Rep Power
    9
    Delete other libraries, atleast that was my problem a week ago.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •