Results 1 to 7 of 7

Thread: Stop looting when cap reachs 0

  1. #1
    Normal User
    Join Date
    Aug 2012
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    10
    Rep Power
    5

    Stop looting when cap reachs 0

    I want a persistent action that makes me stop looting everything when cap reachs 0 and start to loot again when get any cap, thats because I am paladin and I dont care about looting and when I got 0 cap the character keeps trying to loot stuffs and waste a lot of time.

    Thanks in advance

  2. #2
    Normal User sirmate's Avatar
    Join Date
    Mar 2012
    Location
    Poland
    Posts
    176
    Mentioned
    2 Post(s)
    Tagged
    3 Thread(s)
    Quoted
    1 Post(s)
    Reputation
    105
    Rep Power
    6
    Code:
    if (cap == 0) then
        setsettings([[Settings\\Looting\\Enabled]], [[no]])
    else
        setsettings([[Settings\\Looting\\Enabled]], [[yes]])
    end
    
    wait(2000, 4000)
    (๏̯͡๏ )

  3. #3
    Normal User
    Join Date
    Aug 2012
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    10
    Rep Power
    5
    thank you very much, simple like that

    edit: should I put it on Action? cus its not working
    Last edited by drgol; 08-14-2012 at 03:23 AM.

  4. #4
    Normal User
    Join Date
    Jul 2012
    Posts
    24
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    11
    Rep Power
    5
    if (cap == 0) then
    setsettings(Settings\\Looting\\Enabled", "no")
    else
    setsettings(Settings\\Looting\\Enabled", "yes")
    end

    wait(2000, 4000)


    Try that instead, im not sure if it would make any diffrence but worth a try

  5. #5
    Normal User
    Join Date
    Jul 2012
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    10
    Rep Power
    5
    Quote Originally Posted by zimmuf View Post
    if (cap == 0) then
    setsettings("Settings\\Looting\\Enabled", "no")
    else
    setsettings("Settings\\Looting\\Enabled", "yes")
    end

    wait(2000, 4000)


    Try that instead, im not sure if it would make any diffrence but worth a try
    I believe you had a syntax error, missing the first quotes in your first parameter of the setsettings function.

  6. #6
    Normal User
    Join Date
    Aug 2012
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    10
    Rep Power
    5
    should I put it on Action > List enable it and thats all?

  7. #7
    Banned
    Join Date
    May 2012
    Location
    Rio de Janero - RJ / Canada
    Posts
    870
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    30
    Rep Power
    0
    drgol his action stop looting if ur cap is exactly 0, u should try
    if (cap <= 10) then
    setsettings([[Settings\\Looting\\Enabled]], [[no]])
    else
    setsettings([[Settings\\Looting\\Enabled]], [[yes]])
    end

    wait(2000, 4000)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •