Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: My Action doesn't work

  1. #1
    Normal User Sahar's Avatar
    Join Date
    Sep 2012
    Posts
    1,018
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    21
    Rep Power
    7

    My Action doesn't work

    I posted in bugs also here also in releases you destroyed the bot with the R07 and all this versions... getnewmessage works like a shit with big delay.. my syncronize actions doesnt work anymore... i lose all my vouchers all my hcars have full stamina...

    PHP Code:
    local SPELL1 "exori hur"   
    local SPELL2 "exori ico"   
    local CREATURES = {"Dragon""Dragon Lord"}   

    local MESSAGES getnewmessages("Server Log")   
    local MESSAGES_QUANTITY MESSAGES.count 1   
    if (target.id 0) and (target.dist <= 2) and (table.find(CREATURES,target.name)) then   
        
    for INDEX 0MESSAGES_QUANTITY do   
            if (
    MESSAGES[MESSAGES_QUANTITY INDEX].text:find("(.+) loses (.+) hitpoints due to your attack.")) then   
                 
    if cancast(SPELL1then  
                usehotkey
    ("F8"wait(cooldown(SPELL1))  
                elseif 
    cancast(SPELL2then  
                    usehotkey
    ("F9"wait(cooldown(SPELL2))  
                    break 
                
    end   
            end   
        end   
    end 

  2. #2
    Focus Group MoS's Avatar
    Join Date
    Feb 2012
    Posts
    832
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    63 Post(s)
    Reputation
    77
    Rep Power
    6
    yeh, sure... because the bot is all about this action
    this action doesnt work normally = END OF BOT

    u're losing how much exp/h without this action... 20-30k/h? if its a hardcore script, you should care about the exori/min/gran spells, not hur/ico

    dont make a storm in a glass of water
    Ajudei você? ...............+REP
    -----------------------------------------
    Did I help you? ..........+REP

  3. #3
    Normal User Sahar's Avatar
    Join Date
    Sep 2012
    Posts
    1,018
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    21
    Rep Power
    7
    Is that matter how much I lose? If you can help me then thanks..

    I dont see why its not working anymore... what has changed?

  4. #4
    iScripter Eli's Avatar
    Join Date
    Mar 2012
    Posts
    3,764
    Mentioned
    492 Post(s)
    Tagged
    2 Thread(s)
    Quoted
    956 Post(s)
    Reputation
    586
    Rep Power
    10
    Sahar, honestly it's your last warning. Don't spam cause one of ur actions doesn't work.

  5. #5
    Focus Group Gryllz's Avatar
    Join Date
    Jun 2012
    Location
    Dubai
    Posts
    3,482
    Mentioned
    89 Post(s)
    Tagged
    1 Thread(s)
    Quoted
    236 Post(s)
    Reputation
    342
    Rep Power
    10
    Quote Originally Posted by Sahar View Post
    Is that matter how much I lose?
    Quote Originally Posted by Sahar View Post
    i lose all my vouchers all my hcars have full stamina...
    Anyway I will try to find a solution.

  6. #6
    Focus Group MoS's Avatar
    Join Date
    Feb 2012
    Posts
    832
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    63 Post(s)
    Reputation
    77
    Rep Power
    6
    Quote Originally Posted by Sahar View Post
    Is that matter how much I lose? If you can help me then thanks..

    I dont see why its not working anymore... what has changed?
    it already happened to me once, but it didnt affect the exp or profit... the monitor my hunting HUD and a recent loot HUD couldnt work at the same time.. just 1 could work, try turning off some other actions and check if it solves, then you know whats causing it the delay

    also, i posted because u were way too dramatic.. "destroyed the bot", seriously, dont say that, u dont even know what u said haha
    Ajudei você? ...............+REP
    -----------------------------------------
    Did I help you? ..........+REP

  7. #7
    iScripter Eli's Avatar
    Join Date
    Mar 2012
    Posts
    3,764
    Mentioned
    492 Post(s)
    Tagged
    2 Thread(s)
    Quoted
    956 Post(s)
    Reputation
    586
    Rep Power
    10
    changed thread name and moved to correct section.

    PS. As far as I know jonatas will relase today 2.2.5 version of iBot, there will be fixed all bugs which apper with new looting system.

  8. #8
    Normal User Sahar's Avatar
    Join Date
    Sep 2012
    Posts
    1,018
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    21
    Rep Power
    7
    Last warning? Eli, you don't thread anyone.. spam? Where? You can ban me.. I posted in 2 threads and created one. This community is dying and moving for the other bot, you wanna kill it more? Go for it. You think you can ban me just like you can ban a newbie? Go ahead. All I am asking is to know why the hell it's not working anymore... and seems like you and the focus group cant give an honest answer. Is it the "getnewmessage"? Is it a bug even? Or something I can fix or I must wait for next version?

    P.S

    Yeah looting system I don't have problems. but what's the bug in my action? Do you know? And will he fix it?

    P.S mos I dont even use hud..

  9. #9
    iScripter Eli's Avatar
    Join Date
    Mar 2012
    Posts
    3,764
    Mentioned
    492 Post(s)
    Tagged
    2 Thread(s)
    Quoted
    956 Post(s)
    Reputation
    586
    Rep Power
    10
    Quote Originally Posted by Sahar View Post
    Last warning? Eli, you don't thread anyone.. spam? Where? You can ban me.. I posted in 2 threads and created one. This community is dying and moving for the other bot, you wanna kill it more? Go for it. You think you can ban me just like you can ban a newbie? Go ahead. All I am asking is to know why the hell it's not working anymore... and seems like you and the focus group cant give an honest answer. Is it the "getnewmessage"? Is it a bug even? Or something I can fix or I must wait for next version?

    P.S

    Yeah looting system I don't have problems. but what's the bug in my action? Do you know? And will he fix it?

    P.S mos I dont even use hud..
    Maybe it's time for you to move? It's cause of getnewmessages() works slower then before, the new looting system affect some other functions like even targeting, jonatas atm working hard to fix all bugs so stay tunned.


    @Why I should ban you?

    1. You made a fake event
    2. You tried to chargeback one seller around.
    3. You're making propaganda.
    4. You're simply spamming.

    Please note I wont figh with you here, if you want to keep talk msg me on skype.

  10. #10
    Normal User Sahar's Avatar
    Join Date
    Sep 2012
    Posts
    1,018
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    21
    Rep Power
    7
    Fake event - when I was about to finish my event - all my chars got deleted. Remember? Well if you don't please go to my project and check it out. What funny is you know the best, you played on celesta with me, remember?

    Chargeback - we came to a solution. I got a broken link error 00030000.

    Spamming - well yeah I wanted a solution and nobody helps here, but when people need help I always help them. That's the end of the discussion man..

    and for the topic, thanks for answer. Cya.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •