Results 1 to 3 of 3

Thread: Linhas brancas entre cada linha de código depois de usar Notepad++ ou Dreamweaver

  1. #1
    iBot User
    Join Date
    Sep 2012
    Posts
    239
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    46 Post(s)
    Reputation
    23
    Rep Power
    5

    Linhas brancas entre cada linha de código depois de usar Notepad++ ou Dreamweaver

    Eu uso Notepad++ para copiar coisas de um script para outro. Eu formatei o meu PC e não lembro qual opção de encoding ou seja lá o que eu fiz que não criava essas linhas brancas quando eu copiava partes de um script para o outro.

    Exemplo. Usando Notepad++, Eu copio as linhas abaixo para outro script:

    if posx > 13050 then;
    gotolabel("exit");
    end;
    E após salvar e carregar o script, o iBot vai mostrar o código assim:

    if posx > 13050 then

    gotolabel("exit")

    end
    Como arrumar isso?

    Aliás, eu tive esse mesmo problema com o Dreamweaver também. Teste você mesmo: abra o seu iBot, crie um waypoint action e adicione algumas linhas aleatórias de código. Salve esse script com 2 diferente nomes. Agora abra ambos scripts com o Notepad++ ou Dreamweaver e copie tudo de um script para o outro, e os salve.

    O script que você copiou para ele vai monstrar linhas brancas entre as linhas de código quando você abrí-lo e visualizá-lo no iBot novamente.

  2. #2
    iBot User Ragekemi's Avatar
    Join Date
    Sep 2012
    Posts
    300
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    3 Post(s)
    Reputation
    15
    Rep Power
    5
    Quote Originally Posted by john86 View Post
    Eu uso Notepad++ para copiar coisas de um script para outro. Eu formatei o meu PC e não lembro qual opção de encoding ou seja lá o que eu fiz que não criava essas linhas brancas quando eu copiava partes de um script para o outro.

    Exemplo. Usando Notepad++, Eu copio as linhas abaixo para outro script:



    E após salvar e carregar o script, o iBot vai mostrar o código assim:



    Como arrumar isso?

    Aliás, eu tive esse mesmo problema com o Dreamweaver também. Teste você mesmo: abra o seu iBot, crie um waypoint action e adicione algumas linhas aleatórias de código. Salve esse script com 2 diferente nomes. Agora abra ambos scripts com o Notepad++ ou Dreamweaver e copie tudo de um script para o outro, e os salve.

    O script que você copiou para ele vai monstrar linhas brancas entre as linhas de código quando você abrí-lo e visualizá-lo no iBot novamente.
    usa um substiuir todos os ";" por " " (espaço em branco")

    -edit
    Explicando melhor, cada símbolo ";" é uma quebra de linha, ou seja, cada "enter" no seu script é referente à um comma period (ponto virgula), então para simplesmente não ter as linhas brancas remova todos os ";" , lembrando que ao copiar novamente para o bloco de notas o script vai ficar sem espaçamento vertical

  3. #3
    iBot User
    Join Date
    Sep 2012
    Posts
    239
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    46 Post(s)
    Reputation
    23
    Rep Power
    5
    Quote Originally Posted by Ragekemi View Post
    usa um substiuir todos os ";" por " " (espaço em branco")

    -edit
    Explicando melhor, cada símbolo ";" é uma quebra de linha, ou seja, cada "enter" no seu script é referente à um comma period (ponto virgula), então para simplesmente não ter as linhas brancas remova todos os ";" , lembrando que ao copiar novamente para o bloco de notas o script vai ficar sem espaçamento vertical
    Eu já sabia disso, mas é trabalhoso demais, até porque o ";" é usado de outras maneiras que quebraria o script, tal como > e < são salvos como &gt; e &lt;. Fiz diferente. No Notepad++ eu selecionei todos os waypoints, dei CTRL + F e fui em "Replace", em Search Mode eu selecionei "Extended (\n, \r, \t, \0, \x...)" e mandei o Notepad++ substituir todos os \n por nada. Isso é bem mais seguro do que apagar os ";".

    Esse "\n" invisível, que significa nova linha, é criado quando você copia um bloco de texto de um script para o outro. Você não o vê, mas ele está lá!

    Se alguém souber outra maneira, pode postar que eu testo. Se tivesse como remover a inserção automática pelo Notepad++ desse \n toda vez que você cola um texto, o problema talvez seria resolvido.
    Last edited by john86; 01-07-2014 at 06:38 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •