Results 1 to 7 of 7

Thread: Some errors in the debug. Looting crash!

  1. #1
    Normal User
    Join Date
    Jan 2014
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    10
    Rep Power
    3

    Some errors in the debug. Looting crash!

    I noticed that the bot wasn't looting, and checked that when I put the option like this: "Looting corpses with selected items", it doesn't loot at all.
    I changed it to "Loot all corpses" and it started to loot.

    I checked the debug, and this message keeps appearing ALL time, and appears much more massively when a monster dies and you get the message with the loot.

    14:52 : GUI:Channel:Update - System.ArgumentOutOfRangeException: startIndex no puede ser mayor que la longitud de la cadena.
    Nombre del parámetro: startIndex
    en System.String.InternalSubStringWithChecks(Int32 startIndex, Int32 length, Boolean fAlwaysCopy)
    en iBot.GUI.Channel.CheckMessages(Message message)
    en iBot.GUI.Channel.Update()

    This started to happen me at the last update of Ibot.
    If someone can help would be appreciated!!

    Thanks!

  2. #2
    Normal User
    Join Date
    Jan 2014
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    10
    Rep Power
    3
    Bring
    Up
    My
    Post

  3. #3
    Normal User RafiXWPT's Avatar
    Join Date
    Jun 2012
    Location
    (Poland) http://rafixwptscripts.com
    Posts
    1,602
    Mentioned
    31 Post(s)
    Tagged
    1 Thread(s)
    Quoted
    128 Post(s)
    Reputation
    128
    Rep Power
    9
    Try to delete ALL IBot files and download IBot again.

  4. #4
    Normal User catok's Avatar
    Join Date
    Jan 2013
    Location
    Sweden
    Posts
    94
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    14
    Rep Power
    4
    Was it using browse field for all types of corpses?
    Hard Working Scripter



    My Free Scripts:

    Knight
    EK - Mutated Mountains 50+ (option to hunt any tower)

  5. #5
    Normal User
    Join Date
    Jan 2013
    Posts
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    10
    Rep Power
    4
    @Rafi, already done it but get same result. Randomly it happens.

    @Catok, It doesn't use browse field unless a monster dies over a corpse which hadn't been looted. :P

  6. #6
    iBot User
    Join Date
    Sep 2012
    Posts
    239
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    46 Post(s)
    Reputation
    23
    Rep Power
    5
    I sometimes get this problem as well. Not sure why it happens.

    Do you have any loot set to a Destination (container name or index) that is not open?

    Another question (for anyone): what do I put in an item's Destination to stop the item from being looted?
    Last edited by john86; 04-10-2014 at 03:08 PM.

  7. #7
    iBot User walukasz's Avatar
    Join Date
    Feb 2012
    Location
    Poland
    Posts
    312
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    25 Post(s)
    Reputation
    67
    Rep Power
    5
    Quote Originally Posted by john86 View Post
    I sometimes get this problem as well. Not sure why it happens.

    Do you have any loot set to a Destination (container name or index) that is not open?

    Another question (for anyone): what do I put in an item's Destination to stop the item from being looted?
    You put "off" as destination



    about thread, try to clear server log when it happens.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •