Results 1 to 6 of 6

Thread: Connect Problem

  1. #1
    Moderator Furieri's Avatar
    Join Date
    Jun 2012
    Location
    Vitoria - ES / Brasil
    Posts
    792
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    199 Post(s)
    Reputation
    158
    Rep Power
    7

    Connect Problem

    Hello everyone, this multi reconnect is working 100% by mexicowss but, i want to use train statue, i tried and it didn't work, the char log out but not reconect.

    Quero usar essa action de connect para usar statua de treino ao invés do logout, eu substitui o logout pra ele usar a estátua mas ele não conecta no proximo char após usar statua.
    Lua Code:
     
    local ACC = "xxxx" --conta
    local PASS = "xxxx" --senha
    local CHARS = {"Maidein Brazil Cogu","Mousesports Cyx","Natus Vincere Markeloff","Pentagram Neo"} --chars da conta
    local label1 = 'gotodp'--label para ir apos relogar
     
    local INDEX_CHAR 
    if (stamina <= 900 and pzone) then -- Stamina em minutos, 900 = 15 Horas.
        for INDEX, CHAR_NAME in ipairs(CHARS) do 
            if (name == CHAR_NAME) then 
                INDEX_CHAR = INDEX 
            end 
        end 
        if (INDEX_CHAR == #CHARS) then 
            INDEX_CHAR = 0 
        end 
        setcavebot("no") wait(3000, 4500) 
        --useitem(16198, 32247, 31064, 6) -- To use train statue
        logout() wait(3000, 4500)  -- I changed to use statue to logout but it isan't working
        wait(5000)
        connect(ACC, PASS, CHARS[INDEX_CHAR + 1]) wait(3000, 4500) 
        gotolabel(label1) wait(3000, 4500)
        setcavebot("yes") wait(3000, 4500) 
    end


    EDIT: Resolvido, adicionei um wait de 5 segundos e funfou como pensei ele ia pro connect logo deposi que usou a statua e não estava deslogado ainda.
    Last edited by Furieri; 06-12-2014 at 03:13 PM. Reason: Resolvido

  2. #2
    Focus Group Targets's Avatar
    Join Date
    Nov 2013
    Location
    PoA - Brazil
    Posts
    456
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    48 Post(s)
    Reputation
    109
    Rep Power
    5
    Ve até onde ele ta indo....
    se tu não mudo o local label1, creio que possa ser aí... mas testa assim e responde até onde ele ta aparecendo as mensagens

    e ve se na mensagens do chars ele mostra o nome direitinho do char
    Lua Code:
     
     
    local ACC = "xxxx" --conta
    local PASS = "xxxx" --senha
    local CHARS = {"Maidein Brazil Cogu","Mousesports Cyx","Natus Vincere Markeloff","Pentagram Neo"} --chars da conta
    local label1 = 'gotodp'--label para ir apos relogar
     
    local INDEX_CHAR 
    if (stamina <= 900 and pzone) then -- Stamina em minutos, 900 = 15 Horas.
        for INDEX, CHAR_NAME in ipairs(CHARS) do 
            if (name == CHAR_NAME) then
                message("Dentro do loop do char: "..CHARS[INDEX]) -- Pode tirar caso não queira que apareça as mensagens
                INDEX_CHAR = INDEX 
            end 
        end 
        message("1")
        if (INDEX_CHAR == #CHARS) then 
            INDEX_CHAR = 0 
        end
        message("2")
        setcavebot("no") wait(3000, 4500)
        message("3")
        logout() wait(3000, 4500)  -- I changed to use statue to logout but it isan't working
            message("4")
        connect(ACC, PASS, CHARS[INDEX_CHAR + 1]) wait(3000, 4500)
            message("5")
        gotolabel(label1) wait(3000, 4500)
            message("6")
        setcavebot("yes") wait(3000, 4500)
            message("7")
    end



  3. #3
    Moderator Furieri's Avatar
    Join Date
    Jun 2012
    Location
    Vitoria - ES / Brasil
    Posts
    792
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    199 Post(s)
    Reputation
    158
    Rep Power
    7
    Não é no label 1 pq ele não reconecta e sim, eu mudei

  4. #4
    Moderator Furieri's Avatar
    Join Date
    Jun 2012
    Location
    Vitoria - ES / Brasil
    Posts
    792
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    199 Post(s)
    Reputation
    158
    Rep Power
    7
    Quote Originally Posted by Targets View Post
    Ve até onde ele ta indo....
    se tu não mudo o local label1, creio que possa ser aí... mas testa assim e responde até onde ele ta aparecendo as mensagens

    e ve se na mensagens do chars ele mostra o nome direitinho do char
    Lua Code:
     
     
    local ACC = "xxxx" --conta
    local PASS = "xxxx" --senha
    local CHARS = {"Maidein Brazil Cogu","Mousesports Cyx","Natus Vincere Markeloff","Pentagram Neo"} --chars da conta
    local label1 = 'gotodp'--label para ir apos relogar
     
    local INDEX_CHAR 
    if (stamina <= 900 and pzone) then -- Stamina em minutos, 900 = 15 Horas.
        for INDEX, CHAR_NAME in ipairs(CHARS) do 
            if (name == CHAR_NAME) then
                message("Dentro do loop do char: "..CHARS[INDEX]) -- Pode tirar caso não queira que apareça as mensagens
                INDEX_CHAR = INDEX 
            end 
        end 
        message("1")
        if (INDEX_CHAR == #CHARS) then 
            INDEX_CHAR = 0 
        end
        message("2")
        setcavebot("no") wait(3000, 4500)
        message("3")
        logout() wait(3000, 4500)  -- I changed to use statue to logout but it isan't working
            message("4")
        connect(ACC, PASS, CHARS[INDEX_CHAR + 1]) wait(3000, 4500)
            message("5")
        gotolabel(label1) wait(3000, 4500)
            message("6")
        setcavebot("yes") wait(3000, 4500)
            message("7")
    end
    Testei aqui man, e ele faz todos os passos 1 por um, mas não sei pq ele não conecta no char mesmo logado

  5. #5
    Focus Group Targets's Avatar
    Join Date
    Nov 2013
    Location
    PoA - Brazil
    Posts
    456
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    48 Post(s)
    Reputation
    109
    Rep Power
    5
    tenta cria uma local com o nome do char em vez de usa o CHAR[Index]

    e na hora de verifica... essa local recebe o nome do char e la no conect usa ela



  6. #6
    Moderator Furieri's Avatar
    Join Date
    Jun 2012
    Location
    Vitoria - ES / Brasil
    Posts
    792
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    199 Post(s)
    Reputation
    158
    Rep Power
    7
    Quote Originally Posted by Targets View Post
    tenta cria uma local com o nome do char em vez de usa o CHAR[Index]

    e na hora de verifica... essa local recebe o nome do char e la no conect usa ela
    Coloquei solved, adicionei um wait funfou

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •