Results 1 to 2 of 2

Thread: 2 Actions

  1. #1
    Banned
    Join Date
    May 2012
    Location
    Rio de Janero - RJ / Canada
    Posts
    870
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    30
    Rep Power
    0

    2 Actions

    Ive problem with 2 actions
    first:
    moveitems(Pot_Id,Mainbpname,BpManas,100)
    The script works but its annoying to get that message on debug, how do i fix it??
    03:32 CaveBot:Input:FindItemLocal - System.NullReferenceException: Object reference not set to an instance of an object.
    at iBot.CaveBot.Input.FindItemLocal(String item, String local, Boolean move, Int32 index)


    second problem:
    fixed the second
    Last edited by Phillipefn; 06-29-2012 at 07:01 AM.

  2. #2
    iBot User morgul's Avatar
    Join Date
    May 2012
    Location
    Poland, on Tibia Iridia
    Posts
    74
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    12
    Rep Power
    5
    item_id your item to move... for exemple write there: "strong mana potion" or item_id = "strong mana potion" in Setup
    bp_id like up, but It's a backpack xD.

    If u move item to backpack can use only it:- amount of item not

    Code:
    moveitems(item_id, bp_id)
    It's 100% working so maybe u have error in Setup: it's not action and if u add it in Setup then write only

    Code:
    ----Setup
    bp_id = "backpack"      --it's brown backpack
    item_id = "strong mana potion"
    don't use init start, init end ... it's not neo bot
    Last edited by morgul; 06-30-2012 at 07:21 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •