Results 1 to 5 of 5

Thread: Problem with getsetting

  1. #1
    iBot User
    Join Date
    Jun 2012
    Posts
    52
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    10
    Rep Power
    5

    Problem with getsetting

    I've made this thing:

    PHP Code:
    getsetting("Settings/Actions/Enabled"
    but it return me

    Code:
    08:23 : LUA:PersistentAction - LuaInterface.LuaScriptException: [string "chunk"]:1: attempt to call global 'getsetting' (a nil value)
    Whats wrong?

  2. #2
    Banned
    Join Date
    May 2012
    Location
    Rio de Janero - RJ / Canada
    Posts
    870
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    30
    Rep Power
    0
    getsettings

  3. #3
    iBot User
    Join Date
    Jun 2012
    Posts
    52
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    10
    Rep Power
    5
    works lol, thanks

    I used without 's' cause of
    http://www.tibiaibot.com/forum/showt...p?3038-Actions

  4. #4
    Banned
    Join Date
    May 2012
    Location
    Rio de Janero - RJ / Canada
    Posts
    870
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    30
    Rep Power
    0
    ooh, probably his typpo

    whenever u have a problem with those functions, take a look at ibot library and u will see the right function

  5. #5
    iBot User
    Join Date
    Jun 2012
    Posts
    52
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Reputation
    10
    Rep Power
    5
    Ye I checked standard library before but this function does not exist there Thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •